Minimum system requirements for the PhrozenCookie modpack

Requirements This modpack has been built using a computer that’s about 8 years old. We did this to make sure that people with lower end systems can enjoy playing our Minecraft modpack. There are of course always minimum system requirements, if your computer systems meets these minimum requirements this modpack will generally perform quite well. Be aware that the game may have a long loading period if you are trying to play this modpack on a system with an older harddrive, even if your system meets the following minimum requirements. You should at least meet the following requirements: Intel Core2Duo @2.5GHz 64bit capable CPU 4 GB of DDR2 system memory Nvidia 8600 GT with 512MB video memory Windows 7, 8 or 10 Sun Java 8 64bit Also be aware that this pack will only perform smoothly when you have a 64bit system, this is because of the way memory is allocated and addressed by this modpack. You can usually find that out by looking at your total system memory, if you have 4 GB’s of system memory then you are highly likely to have a 64bit capable system. Performance and settings If your system exactly meets these minimum requirements you should close everything else on your PC before starting the launcher and this modpack. Your system will run out of memory fast if you try to play this game while you have a browser opened up, resulting in poor game performance. If you start to experience low frame rates or other types of lag be sure… Read moreMinimum system requirements for the PhrozenCookie modpack